[linux-elitists] USB-Serial and pppd

Greg Folkert greg@gregfolkert.net
Thu Jun 12 12:45:25 PDT 2008


On Thu, 2008-06-12 at 10:09 -0700, Greg KH wrote:
> On Thu, Jun 12, 2008 at 02:27:55AM -0400, Greg Folkert wrote:
> > Ok this one has been itching for a while.
> > 
> > I have an (sierra.ko supported) PCMCIA Slot AC595 EVDO RevA Cellular
> > Broadband card for use with my Verizon service. $65 a
> > month/"unlimited" (fine print claims "unlimited" == 5GiB/month)
> > 
> > Now, I use this card in a couple of different machines.
> > 
> > Machine #1 == Lenovo T61 (6465CTO) T7500 processor, 4GB RAM all Intel
> > Chipset, 200GB disk...etc; Dual Boot WindowsXP and Debian Sid updated
> > nearly daily
> > 
> > Machine #2 == Dell Insirion 8000 850MHz, 512MB RAM, various chipsets
> > included. Single Boot Ubuntu 8.04.
> > 
> > I cannot get anything above 512KiB/sec D/L while in Linux on either
> > machine.
[snip]
> > 
> > I've google'd, Y!'d, MSN'd, Asked Jeeves, Tried to get answers.com,
> > explored the Amazon.com, relied on Wikipedia, Dogpiled on the search,
> > Called on Zuula.com Dawn, saw the clusty.com-fsck, looked in vain for
> > Alta-vista, Did the AOLSEARCH METOO, hit the HOTBOT-ten, tried to
> > looksmart, didn't have a gigablast, Found Live... DEAD, discovered Lycos
> > after Death but came up empty handed, tried direction from DMOZ and
> > finally check alltheweb.
> 
> But you never asked the driver author now did you :)
>
> If so, he would tell you exactly what is wrong (hint, it's the driver,
> not pppd)...
> 
> Use the latest kernel versions, it is a much faster driver than the
> older ones.  If you still have performance issues, let me know and I'll
> show you how to tweak it to go even faster...

Yeah, I didn't want to bother you if I could have found the answer
myself. As to the versions of Kernels... see below.

> > I've read there that usb-serial is known to be slow (and you keep having
> > to repeat yourself)... but that Sierra seems to require it and in fact
> > seems to get in the way. 
> 
> It requires it for the "core" but not for the throughput issues.
> 
> > So, what exactly am I missing? I know I've probably glazed over it and I
> > apologize in advance for re-hashing this again for the umpteenth time.
> > (a quote from a response by g. k-h to someone else recently):
> > 
> > The generic usb serial driver is KNOWN TO BE A VERY SLOW DRIVER!
> > ...
> > The code was not designed to be fast, only get the job done.
> 
> Yes, the "generic" usb-serial driver is slow, as designed.  The sierra
> driver is not using the "generic" driver, but only the usb-serial
> framework, and as such, should be much faster.
>
> What kernel versions are you using in your above configurations?

Okay... my kernels I have in use on the Lenovo machine are Debian
Kernels:

        linux-image-2.6.25-2-686-bigmem v2.6.25-4
        linux-image-2.6.24-1-686-bigmem v2.6.24-6


greg@maxime:/usr/src/linux-source-2.6.25 [0] $ grep -e ^#define\ DRIVER_ \
drivers/usb/serial/sierra.c
#define DRIVER_VERSION "v.1.2.8"
#define DRIVER_AUTHOR "Kevin Lloyd <linux@sierrawireless.com>"
#define DRIVER_DESC "USB Driver for Sierra Wireless USB modems"
greg@maxime:/usr/src/linux-source-2.6.25 [0] $ grep -e ^#define\ DRIVER_ 
drivers/usb/serial/usb-serial.c
#define DRIVER_AUTHOR "Greg Kroah-Hartman, greg@kroah.com, http://www.kroah.com/linux/"
#define DRIVER_DESC "USB Serial Driver core"
greg@maxime:/usr/src/linux-source-2.6.25 [0] $ ls -l drivers/usb/serial/sierra.c \
drivers/usb/serial/usb-serial.c
-rw-r--r-- 1 root root 21078 2008-05-27 08:18 drivers/usb/serial/sierra.c
-rw-r--r-- 1 root root 35444 2008-04-16 22:49 drivers/usb/serial/usb-serial.c

Hope that helps.

I use the 2.6.24 kernel as ACPI/APM/CPUFREQ is screwed up on the 2.6.25
kernel, I only get 800MHz out of this laptop with the 2.6.25 kernel
running along with the cpu frequency scaling stuff.

I had an extended stint in a colo in Denver about 300ft away from a
Verizon Cell tower and only got 512K/sec in Linux period, the guy next
to me had a MacBookPro with a ExpressCard model and same 512K results
came along in my Lenovo using that card. He gets hyarge throughput on
his MacBookPro compared to my T61. I tried on 2.6.24 only as I hadn't
had the time to update to 2.6.25 when it came out. But now it gives
similar results.

And its frustrating, but I'm in this for the long haul no matter what
SCOg thinks, or what Law.com mis-believes about the GPL and IP. Or wrong
thinking/attacks by Microsoft.

Sooo, what is the secret sauce recipe for making things work? Or at
least what ingredients am *I MISSING*?

On this Lenovo, I am running Debian Sid (unstable) plus Joey Hess'
pre-"incoming" repository and plus Experimental for some things and
Christian Marillat's Debian-Multimedia repository for Sid, all of  which
are usually newer than anything in Lenny (Testing).'

BTW, thanks in advance.
-- 
greg@gregfolkert.net
PGP key 1024D/B524687C 2003-08-05
Fingerprint: E1D3 E3D7 5850 957E FED0  2B3A ED66 6971 B524 687C
Alternate Fingerprint: 09F9 1102 9D74  E35B D841 56C5 6356 88C0
Alternate Fingerprint: 455F E104 22CA  29C4 933F 9505 2B79 2AB2
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: This is a digitally signed message part
Url : http://allium.zgp.org/pipermail/linux-elitists/attachments/20080612/da5f7666/attachment.pgp 


More information about the linux-elitists mailing list