[linux-elitists] USB-Serial and pppd

Greg Folkert greg@gregfolkert.net
Wed Jun 11 23:27:55 PDT 2008


Ok this one has been itching for a while.

I have an (sierra.ko supported) PCMCIA Slot AC595 EVDO RevA Cellular
Broadband card for use with my Verizon service. $65 a
month/"unlimited" (fine print claims "unlimited" == 5GiB/month)

Now, I use this card in a couple of different machines.

Machine #1 == Lenovo T61 (6465CTO) T7500 processor, 4GB RAM all Intel
Chipset, 200GB disk...etc; Dual Boot WindowsXP and Debian Sid updated
nearly daily

Machine #2 == Dell Insirion 8000 850MHz, 512MB RAM, various chipsets
included. Single Boot Ubuntu 8.04.

I cannot get anything above 512KiB/sec D/L while in Linux on either
machine.

While in Windows on #1, I get upwards of 2MiB/sec, from the same
location... just rebooting to it with the card in it.

Reboot a second time back into Linux... 512KiB/sec.

Yes, I've gone at length through pppd's options and config files... 

(with or without)921600, compression options out the whing-whang, proper
LCP settings for my provider, crtscts, auth, allthatjazzandabagofchips

I've google'd, Y!'d, MSN'd, Asked Jeeves, Tried to get answers.com,
explored the Amazon.com, relied on Wikipedia, Dogpiled on the search,
Called on Zuula.com Dawn, saw the clusty.com-fsck, looked in vain for
Alta-vista, Did the AOLSEARCH METOO, hit the HOTBOT-ten, tried to
looksmart, didn't have a gigablast, Found Live... DEAD, discovered Lycos
after Death but came up empty handed, tried direction from DMOZ and
finally check alltheweb.

I've come across some amazing docs for getting pppd to work under many
circumstances. Getting it to work through nm-applet (and other similar
mechanisms), ways to tweak pppd to crank throughput. I;ve found very
nice chat scripts for connect and disconnect, parameter files for nearly
any situation under the sun, explanation as to why 921600 is the
currently highest setting, gone through (seemingly hidden) support sites
for said Cellular Card and turned up some gems.

But the one stumper, Nobody I've chatted with nor any URL I've found or
looked at can tell me why usbserial seems to get in the way of sierra,
and have it limited to 512K for transfer rates. pppd seems to work fine
on much higher speeds over other types of media (ethernet, ieee-1394...
etc)

Would anyone here be able to clue me *IN*?

Do I have to use parameters when loading sierra to block usbserial
loading? (I've done some already)

Am I barking up the wrong tree? -> pppd? sierra? 

If I have indeed missed reading an fine manual or article, pleased point
me in the proper direction.

I am asking here, only for getting parity with other OSes. Being sick
and tired of being told SEE Linux isn't better... (I know it is,
though!). A secondary reason is yes, we all know our (my!) favorite
Kernel Hacker lurks here quite a bit, whom also signs the
$KERNEL_SRC/Documentation/usb/usb-serial.txt

I've also tried an ExpressCard Sierra Card on the T61, which I borrowed
from a friend with a MacBook Pro and get similar results under Linux.

If that certain someone would rather me ask the proper mailing list,
just let me know. I should tell you that I have indeed looked (and
perhaps missed) for answers on the archive of that list.

I've read there that usb-serial is known to be slow (and you keep having
to repeat yourself)... but that Sierra seems to require it and in fact
seems to get in the way. 

I've looked at the UDEV rules for making devices related to this card
and even modified and broken them badly, but the only time I can get it
to work is with usbserial loaded. But here is the evidence.

Module                  Size  Used by
sierra                 13860  0 
usbserial              33128  1 sierra
....

maxime:~# modprobe -r usbserial
FATAL: Module usbserial is in use.

So, what exactly am I missing? I know I've probably glazed over it and I
apologize in advance for re-hashing this again for the umpteenth time.
(a quote from a response by g. k-h to someone else recently):

The generic usb serial driver is KNOWN TO BE A VERY SLOW DRIVER!
...
The code was not designed to be fast, only get the job done.


I hope you all followed that, if not ask for clarification, please.

*IF* I get an answer and/or workaround, I will make sure it is blatantly
posted on my very ...umm... lacking website.
-- 
greg@gregfolkert.net
PGP key 1024D/B524687C 2003-08-05
Fingerprint: E1D3 E3D7 5850 957E FED0  2B3A ED66 6971 B524 687C
Alternate Fingerprint: 09F9 1102 9D74  E35B D841 56C5 6356 88C0
Alternate Fingerprint: 455F E104 22CA  29C4 933F 9505 2B79 2AB2
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: This is a digitally signed message part
Url : http://allium.zgp.org/pipermail/linux-elitists/attachments/20080612/7982bc76/attachment.pgp 


More information about the linux-elitists mailing list